Tuesday, April 12, 2016

Blue is a nice color but not on my monitor!

My plan for Saturday was to spend some time on the radio and possibly make some contacts in the QRP ARCI Spring QSO party. I was at the radio 8:30 local time with the PC and K3 humming, I was not really able to find much action on the bands most of the day for this contest. I decided to do some blogging while I was surfing the bands. Late in the afternoon my mouse stopped working and then it came back, then a short time later my screen froze. I restated the PC and I noticed some ADIF files on my desktop that normally displayed as a sheet of paper now looked like brown filing cabinet drawers, that was very odd and has never happened before. Then it happened the screen turned blue, there was long string of codes displayed and then a memory dump and a restart. The PC seemed stable once it restarted but after a short time the same happened again and again. I was able to boot in safe mode and access Event viewer and see the error codes from the blue screen. From there I did a google search and found it could be a RAM, heat or a CPU issue. At this time Julie and I had to go out so I shut the PC down, 3 hours later I restarted the PC and it seemed to work without issue. This lead me to believe it was an overheating issue and I would look into it in detail on Sunday.
Crammed cards

Below is what I did on Sunday to sort through this issue:
I began with opening up the side panel on the tower checking for dirt, dust loose    wires. The PC was clean and no loose cables. 
I then started the PC while checking to see if the fans on the CPU and video card were working and they both were. 
I did notice the video card was mounted right on top on my video capture card.     The heat of the capture card was rising up to the video card.  So I moved the video card to give it more room on the mother board and to give it more air flow. 
I then downloaded  CPUID HWMonitor and Coretemp his way I could see temp readings of the system. HWMonitor showed the video card was running hot at 60C and higher when the card was being used The CPU fan seemed to be cycling a lot from low to high speed as the temp rose. What adds to my heat problem is the PC is located in my roll top desk tucked in a “cubby” with no air flow. Also in the same location I have my Astron power supply that was on all day feeding my K3. I removed my PC from the location in the roll top to the floor and the temperature improved but still a bit high. 
To improve my cooling I have ordered two fans for the tower to have air flow in and out of the tower, also I am removing the desk back panel in lower section to allow the hot air to escape.
Video card moved to bottom

Next I wanted to check all I could on the PC to make sure all other components were running ok as this may just not be a heat issue. 
I did the following:
1. On each of my 3 drives I ran Check disc and all drives passed. 
2. I ran memory check to see if the ram was ok and it passed. 
3. Spybot was the next program to run which found 20 issues and repaired them.
4. CCleaner found some issues and repaired them. 
5. I then defragmented all the drives. 
6. Avast did a virus scan without any issues
The cramped quarters 
7. I then ran widows update and there were a few updates that downloaded. 
8. I then went into the BIOS and changed the CPU fan setting to run full speed all the time. This significantly reduced the CPU temp. 
9. I then for the heck of it updated the BIOS as well. 
I was on the PC most of the day today and part of the evening and there was no issues. I am hoping it was just a heat issue and by adding the tower fans and opening up the back panel the issue will not happen again. 

4 comments:

  1. Hello Mike, computers, computers....if they work it's nice. But if not it gives a lot of stress. Had several issues with my desktop in the past. But luckely the last 2 years not a problem at all. Hope your problem has been solved forever now. 73, Bas

    ReplyDelete
    Replies
    1. Good evening Bas, I must say that over the long run I have been very lucky with computers and not many issues. I find it challenging to trouble shoot and we do have more than one computer in the house so I'm not left with nothing.
      73, Mike

      Delete
  2. Hi Mike, as Bas said, computers... just like cars, they should work. I got some problems yesterday. BIOS problems. It took some while to fix it. It took me a whole day... 73 Paul PC4T

    ReplyDelete
    Replies
    1. Nice to hear from you Paul, it's funny that one day the PC is purring like a kitten and the next day for no reason you have to spend all day to fix an issue. Glad to hear you were able to get things up and running again.
      Have a great weekend.
      73, Mike

      Delete